Discussion:
Neo4j 2.0.0-RC1 install on Mac OS X 10.8.5
(too old to reply)
Matthew Barry
2013-12-09 18:17:34 UTC
Permalink
I'm trying to run Neo4j 2.0 in order to use labels. Downloaded 2.0.0-RC1
and installed Oracle's JDK 7. Cannot start the server, receiving Java
exceptions. Is there a class path problem with the launch script? Has
anyone seen similar and solved it?
:neo4j-community-2.0.0-RC1 mrb$ neo4j console
WARNING: Max 256 open files allowed, minimum of 40 000 recommended. See the
Neo4j manual.
Starting Neo4j Server console-mode...
Using additional JVM arguments: -server -XX:+DisableExplicitGC -Dorg.neo4j.
server.properties=conf/neo4j-server.properties -Djava.util.logging.config.
file=conf/logging.properties -Dlog4j.configuration=file:conf/log4j.properties
-XX:+UseConcMarkSweepGC -XX:+CMSClassUnloadingEnabled
2013-12-09 06:36:42.132+0000 INFO [API] Setting startup timeout to:
120000ms based on -1
Detected incorrectly shut down database, performing recovery..
2013-12-09 06:36:43.086+0000 INFO [API] Successfully started database
2013-12-09 06:36:43.177+0000 DEBUG [API]
org.neo4j.server.ServerStartupException: Starting Neo4j Server failed: scala
/Function0
at org.neo4j.server.AbstractNeoServer.start(AbstractNeoServer.java:209) ~[
neo4j-server-2.0.0-RC1.jar:2.0.0-RC1]
at org.neo4j.server.Bootstrapper.start(Bootstrapper.java:87) [neo4j-server-
2.0.0-RC1.jar:2.0.0-RC1]
at org.neo4j.server.Bootstrapper.main(Bootstrapper.java:50) [neo4j-server-
2.0.0-RC1.jar:2.0.0-RC1]
Caused by: java.lang.NoClassDefFoundError: scala/Function0
at org.neo4j.cypher.javacompat.ExecutionEngine.<init>(ExecutionEngine.java:
53) ~[neo4j-cypher-2.0.0-RC1.jar:2.0.0-RC1]
at org.neo4j.server.AbstractNeoServer.createTransactionalActions(
AbstractNeoServer.java:249) ~[neo4j-server-2.0.0-RC1.jar:2.0.0-RC1]
at org.neo4j.server.AbstractNeoServer.start(AbstractNeoServer.java:164) ~[
neo4j-server-2.0.0-RC1.jar:2.0.0-RC1]
... 2 common frames omitted
Caused by: java.lang.ClassNotFoundException: scala.Function0
at java.net.URLClassLoader$1.run(URLClassLoader.java:366) ~[na:1.7.0_45]
at java.net.URLClassLoader$1.run(URLClassLoader.java:355) ~[na:1.7.0_45]
at java.security.AccessController.doPrivileged(Native Method) ~[na:1.7.0_45
]
at java.net.URLClassLoader.findClass(URLClassLoader.java:354) ~[na:1.7.0_45
]
at java.lang.ClassLoader.loadClass(ClassLoader.java:425) ~[na:1.7.0_45]
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308) ~[na:1.7.
0_45]
at java.lang.ClassLoader.loadClass(ClassLoader.java:358) ~[na:1.7.0_45]
... 5 common frames omitted
2013-12-09 06:36:43.178+0000 DEBUG [API] Failed to start Neo Server on port
[7474]
:neo4j-community-2.0.0-RC1 mrb$
Java reports itself as version 7
:neo4j-community-2.0.0-RC1 mrb$ java -version
java version "1.7.0_45"
Java(TM) SE Runtime Environment (build 1.7.0_45-b18)
Java HotSpot(TM) 64-Bit Server VM (build 24.45-b08, mixed mode)

with environment

JAVA_HOME=/Library/Java/JavaVirtualMachines/jdk1.7.0_45.jdk/Contents/Home


If instead I launch to start, then the terminal says
:neo4j-community-2.0.0-RC1 mrb$ neo4j start
Using additional JVM arguments: -server -XX:+DisableExplicitGC -Dorg.neo4j.
server.properties=conf/neo4j-server.properties -Djava.util.logging.config.
file=conf/logging.properties -Dlog4j.configuration=file:conf/log4j.properties
-XX:+UseConcMarkSweepGC -XX:+CMSClassUnloadingEnabled
Starting Neo4j Server...WARNING: not changing user
process [99248]... waiting for server to be ready.... Failed to start
within 120 seconds.
Neo4j Server may have failed to start, please check the logs.
:neo4j-community-2.0.0-RC1 mrb$
it does not wait more than three seconds let alone 120 seconds before
exiting, and the log file

data/log/neo4j.0.0.log

reports

Dec 09, 2013 12:03:34 PM org.neo4j.server.logging.Logger log
SEVERE: Failed to start Neo Server on port [7474]
:neo4j-community-2.0.0-RC1 mrb$ lsof -i :7474
:neo4j-community-2.0.0-RC1 mrb$
Any suggestions?
--
You received this message because you are subscribed to the Google Groups "Neo4j" group.
To unsubscribe from this group and stop receiving emails from it, send an email to neo4j+unsubscribe-/JYPxA39Uh5TLH3MbocFF+G/***@public.gmane.org
For more options, visit https://groups.google.com/groups/opt_out.
Glenn Hoetker
2013-12-09 18:39:34 UTC
Permalink
From my limited experience, if you have data from earlier versions hanging
around, it can hang with this type of error.
I'm trying to run Neo4j 2.0 in order to use labels. Downloaded 2.0.0-RC1
and installed Oracle's JDK 7. Cannot start the server, receiving Java
exceptions. Is there a class path problem with the launch script? Has
anyone seen similar and solved it?
:neo4j-community-2.0.0-RC1 mrb$ neo4j console
WARNING: Max 256 open files allowed, minimum of 40 000 recommended. Seethe
Neo4j manual.
Starting Neo4j Server console-mode...
Using additional JVM arguments: -server -XX:+DisableExplicitGC -Dorg.
neo4j.server.properties=conf/neo4j-server.properties -Djava.util.logging.
config.file=conf/logging.properties -Dlog4j.configuration=file:conf/log4j.properties
-XX:+UseConcMarkSweepGC -XX:+CMSClassUnloadingEnabled
120000ms based on -1
Detected incorrectly shut down database, performing recovery..
2013-12-09 06:36:43.086+0000 INFO [API] Successfully started database
2013-12-09 06:36:43.177+0000 DEBUG [API]
org.neo4j.server.ServerStartupException: Starting Neo4j Server failed:scala
/Function0
at org.neo4j.server.AbstractNeoServer.start(AbstractNeoServer.java:209)
~[neo4j-server-2.0.0-RC1.jar:2.0.0-RC1]
at org.neo4j.server.Bootstrapper.start(Bootstrapper.java:87) [neo4j-
server-2.0.0-RC1.jar:2.0.0-RC1]
at org.neo4j.server.Bootstrapper.main(Bootstrapper.java:50) [neo4j-server
-2.0.0-RC1.jar:2.0.0-RC1]
Caused by: java.lang.NoClassDefFoundError: scala/Function0
at org.neo4j.cypher.javacompat.ExecutionEngine.<init>(ExecutionEngine.
java:53) ~[neo4j-cypher-2.0.0-RC1.jar:2.0.0-RC1]
at org.neo4j.server.AbstractNeoServer.createTransactionalActions(
AbstractNeoServer.java:249) ~[neo4j-server-2.0.0-RC1.jar:2.0.0-RC1]
at org.neo4j.server.AbstractNeoServer.start(AbstractNeoServer.java:164)
~[neo4j-server-2.0.0-RC1.jar:2.0.0-RC1]
... 2 common frames omitted
Caused by: java.lang.ClassNotFoundException: scala.Function0
at java.net.URLClassLoader$1.run(URLClassLoader.java:366) ~[na:1.7.0_45]
at java.net.URLClassLoader$1.run(URLClassLoader.java:355) ~[na:1.7.0_45]
at java.security.AccessController.doPrivileged(Native Method) ~[na:1.7.
0_45]
at java.net.URLClassLoader.findClass(URLClassLoader.java:354) ~[na:1.7.
0_45]
at java.lang.ClassLoader.loadClass(ClassLoader.java:425) ~[na:1.7.0_45]
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308) ~[na:1.7
.0_45]
at java.lang.ClassLoader.loadClass(ClassLoader.java:358) ~[na:1.7.0_45]
... 5 common frames omitted
2013-12-09 06:36:43.178+0000 DEBUG [API] Failed to start Neo Server on
port [7474]
:neo4j-community-2.0.0-RC1 mrb$
Java reports itself as version 7
:neo4j-community-2.0.0-RC1 mrb$ java -version
java version "1.7.0_45"
Java(TM) SE Runtime Environment (build 1.7.0_45-b18)
Java HotSpot(TM) 64-Bit Server VM (build 24.45-b08, mixed mode)
with environment
JAVA_HOME=/Library/Java/JavaVirtualMachines/jdk1.7.0_45.jdk/Contents/Home
If instead I launch to start, then the terminal says
:neo4j-community-2.0.0-RC1 mrb$ neo4j start
Using additional JVM arguments: -server -XX:+DisableExplicitGC -Dorg.
neo4j.server.properties=conf/neo4j-server.properties -Djava.util.logging.
config.file=conf/logging.properties -Dlog4j.configuration=file:conf/log4j.properties
-XX:+UseConcMarkSweepGC -XX:+CMSClassUnloadingEnabled
Starting Neo4j Server...WARNING: not changing user
process [99248]... waiting for server to be ready.... Failed to start
within 120 seconds.
Neo4j Server may have failed to start, please check the logs.
:neo4j-community-2.0.0-RC1 mrb$
it does not wait more than three seconds let alone 120 seconds before
exiting, and the log file
data/log/neo4j.0.0.log
reports
Dec 09, 2013 12:03:34 PM org.neo4j.server.logging.Logger log
SEVERE: Failed to start Neo Server on port [7474]
:neo4j-community-2.0.0-RC1 mrb$ lsof -i :7474
:neo4j-community-2.0.0-RC1 mrb$
Any suggestions?
--
You received this message because you are subscribed to the Google Groups "Neo4j" group.
To unsubscribe from this group and stop receiving emails from it, send an email to neo4j+unsubscribe-/JYPxA39Uh5TLH3MbocFF+G/***@public.gmane.org
For more options, visit https://groups.google.com/groups/opt_out.
Peter Neubauer
2013-12-10 11:43:19 UTC
Permalink
Matthew,
do you have a system-wide neo4j installed already?
:neo4j-community-2.0.0-RC1 mrb$ neo4j console
This should be ./bin/neo4j console, so it seems `neo4j` is already on
your PATH somewhere else? Can you do

which neo4j

and check?

/peter

G: neubauer.peter
S: peter.neubauer
P: +46 704 106975
L: http://www.linkedin.com/in/neubauer
T: @peterneubauer

Neo4j 2.0.0-RC1 -
http://blog.neo4j.org/2013/11/neo4j-200-rc1-final-preparations.html
Kidscraft "Ice" - http://www.kidscraft.se/
I'm trying to run Neo4j 2.0 in order to use labels. Downloaded 2.0.0-RC1
and installed Oracle's JDK 7. Cannot start the server, receiving Java
exceptions. Is there a class path problem with the launch script? Has
anyone seen similar and solved it?
:neo4j-community-2.0.0-RC1 mrb$ neo4j console
WARNING: Max 256 open files allowed, minimum of 40 000 recommended. See the
Neo4j manual.
Starting Neo4j Server console-mode...
Using additional JVM arguments: -server -XX:+DisableExplicitGC
-Dorg.neo4j.server.properties=conf/neo4j-server.properties
-Djava.util.logging.config.file=conf/logging.properties
-Dlog4j.configuration=file:conf/log4j.properties -XX:+UseConcMarkSweepGC
-XX:+CMSClassUnloadingEnabled
120000ms based on -1
Detected incorrectly shut down database, performing recovery..
2013-12-09 06:36:43.086+0000 INFO [API] Successfully started database
2013-12-09 06:36:43.177+0000 DEBUG [API]
scala/Function0
at org.neo4j.server.AbstractNeoServer.start(AbstractNeoServer.java:209)
~[neo4j-server-2.0.0-RC1.jar:2.0.0-RC1]
at org.neo4j.server.Bootstrapper.start(Bootstrapper.java:87)
[neo4j-server-2.0.0-RC1.jar:2.0.0-RC1]
at org.neo4j.server.Bootstrapper.main(Bootstrapper.java:50)
[neo4j-server-2.0.0-RC1.jar:2.0.0-RC1]
Caused by: java.lang.NoClassDefFoundError: scala/Function0
at
org.neo4j.cypher.javacompat.ExecutionEngine.<init>(ExecutionEngine.java:53)
~[neo4j-cypher-2.0.0-RC1.jar:2.0.0-RC1]
at
org.neo4j.server.AbstractNeoServer.createTransactionalActions(AbstractNeoServer.java:249)
~[neo4j-server-2.0.0-RC1.jar:2.0.0-RC1]
at org.neo4j.server.AbstractNeoServer.start(AbstractNeoServer.java:164)
~[neo4j-server-2.0.0-RC1.jar:2.0.0-RC1]
... 2 common frames omitted
Caused by: java.lang.ClassNotFoundException: scala.Function0
at java.net.URLClassLoader$1.run(URLClassLoader.java:366) ~[na:1.7.0_45]
at java.net.URLClassLoader$1.run(URLClassLoader.java:355) ~[na:1.7.0_45]
at java.security.AccessController.doPrivileged(Native Method)
~[na:1.7.0_45]
at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
~[na:1.7.0_45]
at java.lang.ClassLoader.loadClass(ClassLoader.java:425) ~[na:1.7.0_45]
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
~[na:1.7.0_45]
at java.lang.ClassLoader.loadClass(ClassLoader.java:358) ~[na:1.7.0_45]
... 5 common frames omitted
2013-12-09 06:36:43.178+0000 DEBUG [API] Failed to start Neo Server on port
[7474]
:neo4j-community-2.0.0-RC1 mrb$
Java reports itself as version 7
:neo4j-community-2.0.0-RC1 mrb$ java -version
java version "1.7.0_45"
Java(TM) SE Runtime Environment (build 1.7.0_45-b18)
Java HotSpot(TM) 64-Bit Server VM (build 24.45-b08, mixed mode)
with environment
JAVA_HOME=/Library/Java/JavaVirtualMachines/jdk1.7.0_45.jdk/Contents/Home
If instead I launch to start, then the terminal says
:neo4j-community-2.0.0-RC1 mrb$ neo4j start
Using additional JVM arguments: -server -XX:+DisableExplicitGC
-Dorg.neo4j.server.properties=conf/neo4j-server.properties
-Djava.util.logging.config.file=conf/logging.properties
-Dlog4j.configuration=file:conf/log4j.properties -XX:+UseConcMarkSweepGC
-XX:+CMSClassUnloadingEnabled
Starting Neo4j Server...WARNING: not changing user
process [99248]... waiting for server to be ready.... Failed to start within
120 seconds.
Neo4j Server may have failed to start, please check the logs.
:neo4j-community-2.0.0-RC1 mrb$
it does not wait more than three seconds let alone 120 seconds before
exiting, and the log file
data/log/neo4j.0.0.log
reports
Dec 09, 2013 12:03:34 PM org.neo4j.server.logging.Logger log
SEVERE: Failed to start Neo Server on port [7474]
:neo4j-community-2.0.0-RC1 mrb$ lsof -i :7474
:neo4j-community-2.0.0-RC1 mrb$
Any suggestions?
--
You received this message because you are subscribed to the Google Groups "Neo4j" group.
To unsubscribe from this group and stop receiving emails from it, send an
For more options, visit https://groups.google.com/groups/opt_out.
--
You received this message because you are subscribed to the Google Groups "Neo4j" group.
To unsubscribe from this group and stop receiving emails from it, send an email to neo4j+unsubscribe-/JYPxA39Uh5TLH3MbocFF+G/***@public.gmane.org
For more options, visit https://groups.google.com/groups/opt_out.
Matthew Barry
2013-12-10 19:18:47 UTC
Permalink
I wondered about that too. I do not. I used to have 1.9.5 from homebrew
but I uninstalled it before performing the steps above. While
investigating this problem I at one point put ./bin on my PATH to see if it
made a difference for the scripts. I have just reset the PATH to the
minimum and run

./bin/neo4j console


with the same result. Running

which neo4j

returns nothing found.
--
You received this message because you are subscribed to the Google Groups "Neo4j" group.
To unsubscribe from this group and stop receiving emails from it, send an email to neo4j+unsubscribe-/JYPxA39Uh5TLH3MbocFF+G/***@public.gmane.org
For more options, visit https://groups.google.com/groups/opt_out.
Peter Neubauer
2013-12-10 19:47:40 UTC
Permalink
That is strange.

Can you upload that server zipped somewhere for me to test? Dropbox?

/peter

G: neubauer.peter
S: peter.neubauer
P: +46 704 106975
L: http://www.linkedin.com/in/neubauer
T: @peterneubauer

Neo4j 2.0.0-RC1 -
http://blog.neo4j.org/2013/11/neo4j-200-rc1-final-preparations.html
Kidscraft "Ice" - http://www.kidscraft.se/
Post by Matthew Barry
I wondered about that too. I do not. I used to have 1.9.5 from homebrew
but I uninstalled it before performing the steps above. While investigating
this problem I at one point put ./bin on my PATH to see if it made a
difference for the scripts. I have just reset the PATH to the minimum and
run
./bin/neo4j console
with the same result. Running
which neo4j
returns nothing found.
--
You received this message because you are subscribed to the Google Groups "Neo4j" group.
To unsubscribe from this group and stop receiving emails from it, send an
For more options, visit https://groups.google.com/groups/opt_out.
--
You received this message because you are subscribed to the Google Groups "Neo4j" group.
To unsubscribe from this group and stop receiving emails from it, send an email to neo4j+unsubscribe-/JYPxA39Uh5TLH3MbocFF+G/***@public.gmane.org
For more options, visit https://groups.google.com/groups/opt_out.
Peter Neubauer
2013-12-12 14:22:55 UTC
Permalink
Matt,
same thing here.

If you use the new shiny Neo4j 2.0.0, are you still getting that error.

/peter
Post by Peter Neubauer
That is strange.
Can you upload that server zipped somewhere for me to test? Dropbox?
/peter
G: neubauer.peter
S: peter.neubauer
P: +46 704 106975
L: http://www.linkedin.com/in/neubauer
Neo4j 2.0.0-RC1 -
http://blog.neo4j.org/2013/11/neo4j-200-rc1-final-preparations.html
Kidscraft "Ice" - http://www.kidscraft.se/
Post by Matthew Barry
I wondered about that too. I do not. I used to have 1.9.5 from
homebrew
Post by Matthew Barry
but I uninstalled it before performing the steps above. While
investigating
Post by Matthew Barry
this problem I at one point put ./bin on my PATH to see if it made a
difference for the scripts. I have just reset the PATH to the minimum
and
Post by Matthew Barry
run
./bin/neo4j console
with the same result. Running
which neo4j
returns nothing found.
--
You received this message because you are subscribed to the Google
Groups
Post by Matthew Barry
"Neo4j" group.
To unsubscribe from this group and stop receiving emails from it, send
an
Post by Matthew Barry
For more options, visit https://groups.google.com/groups/opt_out.
--
You received this message because you are subscribed to the Google Groups "Neo4j" group.
To unsubscribe from this group and stop receiving emails from it, send an email to neo4j+unsubscribe-/JYPxA39Uh5TLH3MbocFF+G/***@public.gmane.org
For more options, visit https://groups.google.com/groups/opt_out.
Matthew Barry
2013-12-12 15:06:59 UTC
Permalink
Thanks for checking Peter.

The problem does not occur with the new Neo4j 2.0.0, which seems to run fine on this platform.

Matt
Post by Peter Neubauer
Matt,
same thing here.
If you use the new shiny Neo4j 2.0.0, are you still getting that error.
/peter
That is strange.
Can you upload that server zipped somewhere for me to test? Dropbox?
/peter
G: neubauer.peter
S: peter.neubauer
P: +46 704 106975
L: http://www.linkedin.com/in/neubauer
Neo4j 2.0.0-RC1 -
http://blog.neo4j.org/2013/11/neo4j-200-rc1-final-preparations.html
Kidscraft "Ice" - http://www.kidscraft.se/
Post by Matthew Barry
I wondered about that too. I do not. I used to have 1.9.5 from homebrew
but I uninstalled it before performing the steps above. While investigating
this problem I at one point put ./bin on my PATH to see if it made a
difference for the scripts. I have just reset the PATH to the minimum and
run
./bin/neo4j console
with the same result. Running
which neo4j
returns nothing found.
--
You received this message because you are subscribed to the Google Groups
"Neo4j" group.
To unsubscribe from this group and stop receiving emails from it, send an
For more options, visit https://groups.google.com/groups/opt_out.
--
You received this message because you are subscribed to a topic in the Google Groups "Neo4j" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/neo4j/AaoHsBLUjvs/unsubscribe.
For more options, visit https://groups.google.com/groups/opt_out.
Loading...